Degraded performance and intermittent outages
Incident Report for BigBrassBand
Resolved
We've deployed more fixes, and everything seems back to normal
Posted Aug 05, 2022 - 23:31 EDT
Monitoring
We've deployed some fixes.

Everything should be operational again, and CI/CD indexing has been re-enabled as well.

We're leaving the status as "Degraded" for the next several hours, while we monitor performance of the app, and ensure no further issues persist.
Posted Aug 04, 2022 - 22:39 EDT
Identified
For the past ~48 hours we've been experiencing intermittent outages in our "Global", "US", and "EU regions.
This has been affecting indexing of repos, as well as responsiveness of the app within Jira.

We've identified the culprit, and are working towards a fix.
We've temporarily disabled indexing of CI/CD data to stabilize the app.
Expect minor issues and/or degraded performance while we work through deploying a fix.
Posted Aug 04, 2022 - 14:19 EDT
This incident affected: Git Integration for Jira Cloud - US Region (User interface, Repository indexing (commits/branches/pull requests)), Git Integration for Jira Cloud - Global Region (User Interface, API, Repository indexing (commits/branches/pull requests), Smart Commits Processing), and Git Integration for Jira Cloud - EU Region (User Interface, Repository indexing (commits/branches/pull requests)).