Microsoft OAuth integrations not indexing
Incident Report for BigBrassBand
Resolved
This incident has been resolved.
Posted Mar 05, 2022 - 09:44 EST
Monitoring
A fix has been implemented. Customers who use the the OAuth integration type for Microsoft Azure Repos or Microsoft VSTS will need to reconnect. See https://bigbrassband.atlassian.net/wiki/spaces/GITCLOUD/pages/2079686657/Reconnecting+Azure+DevOps+and+VSTS+OAuth+integrations for instructions on how to reconnect.
Posted Mar 02, 2022 - 23:58 EST
Identified
Microsoft VSTS and Azure DevOps OAuth applications have a bug/limitation where the application secret expires 5 years after creation. This secret cannot be refreshed/updated. The workaround from Microsoft is to create a new OAuth application and have consumer re-connect: https://developercommunity.visualstudio.com/t/client-secret-is-expired-even-after-refresh/1564908

We will be updating production shortly. Once updated, customers will need to reconnect https://cln.sh/26TUNm in the integration settings. If you need assistance with this, please contact support@bigbrassband.com.
Posted Mar 02, 2022 - 18:42 EST
Investigating
We are currently investigating this issue.
Posted Mar 02, 2022 - 18:11 EST
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 02, 2022 - 17:30 EST
This incident affected: Cloud git service providers (Azure DevOps / VSTS).