Some GitLab.com repositories failing to index
Incident Report for BigBrassBand
Resolved
Indexing GitLab.com commits/branches/merge requests is back to normal. While we make some modifications to the indexing engine - we have changed the indexing interval for all repositories/integrations to every 15 minutes (from about every 12 minutes).
Posted Oct 30, 2019 - 13:10 EDT
Identified
Continuing to see sporadic failures with GitLab.com reindexing. Checking other avenues.
Posted Oct 29, 2019 - 19:30 EDT
Monitoring
We have modified the reindex interval and seeing more successful reindexing - but still seeing some lingering errors. We will continue to monitor.
Posted Oct 29, 2019 - 17:49 EDT
Identified
We're seeing permissions and some rate limiting issues in GitLab.com logs. We have temporarily changed the indexing from 7.5 minutes to 15 minutes to make fewer API requests to GitLab.com. All indexing (except webhook triggered indexing) is now on 15 minute intervals.
Posted Oct 29, 2019 - 16:50 EDT
Investigating
We are currently investigating this issue.
Posted Oct 29, 2019 - 14:59 EDT
This incident affected: Git Integration for Jira Cloud (Repository indexing (commits/branches/pull requests)) and Git service providers (Gitlab.com).